SSH connecting time out delay

Is there a way to lengthen the time out delay on getting an ssh connection? We are running an older mac as a server and, at times, it takes it awhile to get out of bed, brush its teeth, get a cup of coffee and finally open the SSH door.

I looked in the ssh_config file inside VineViewer but nothing seemed to jump out at me.


Actually, yes! The time out can be specified by issuing this command from a Terminal session.

defaults write com.redstonesoftware.Vine MaxVNCTimeout TIME_IN_SECONDS

The default timeout is 16 seconds, so you’ll want to make it larger than that.

Hmmm. I tried the command and to set it to 30 seconds but, unfortunately, I still get a timeout notification between 10 and 16 seconds.

Does this preference also apply for SSH connections?

The Viewer only allows 10 seconds to actually create the initial SSH connection. Normally that should be enough but in some instances you may need just a little bit more. Unfortunately Vine 1.1 doesn’t allow you to increase this value. Vine 1.2 and above (no release date set) and Eggplant 3.4 and above (no release date set) will allow you to increase that delay using this command

defaults write com.redstonesoftware.Vine SSHConnectTimeout TIME_IN_SECONDS

By the way, have you or TypeIt4Me been able to track down the tab issue?

It was just pointed out to me that I actually mistyped those commands, the actual preferences location is .Vine (not .VineViewer). They have been corrected above but anyone who tried them with the wrong ending (and saw no impact) should try again with the correct ending.