Specifying starting directory with Answer File command

I’m trying to use the ‘in folder “xxx”’ option for the Answer File command. No matter what I put as the option, it always seems to default to the root directory on my hard disk.

I’ve tried “~”, “~/” and a host of other things, and nothing works.

Here’s my command:

answer file “Select a file to load:” of type “txt” or “text” or “rtf” in folder “~/”

Is there something I’m missing?

Looks like a bug with relative paths.

This works fine here
answer file in folder “/Library”

Well when you said that /Library worked for you, I tried it myself and it didn’t. Which made me dive a little deeper.

I tried the very simple

answer file in folder “/Library”

and that worked for me, too. It seems to be a problem with parameters.

If I do

answer file of type “txt” or “text” or “rtf” in folder “/Library”

it doesn’t work but if I do

answer file in folder “/Library” of type “txt” or “text” or “rtf”

it does. So yeah, a bug, but not in the partial path stuff. (I tried “~/” again and it works now with the right parameter order.)

Also, in my initial example, I realize I placed a text string thinking that it’d be a prompt in the choose file dialog. That parameter also causes problems and isn’t actually used (although that’s a FEATURE REQUEST, hint, hint).

your right, it is more complicated…

this works perfect
answer file “Select file to load” of type “txt” in folder “~/Documents”

this one goes to the root directory and ignores the text…
answer file “Select file to load” of type “txt” or “html” in folder “~/Documents”


Yes, it appears that a bug crept into a recent release that prevents the use of multiple type filters with this command. It will be fixed in the next Eggplant release.

As bollo notes, you can use a single type filter without any problems.