setting shellCommand

Is there some defaults write I can do so that

the shellCommand

is bash and not sh?

To set it in a script, you can do this:

set the shellCommand to "/bin/bash"

To set the default value using defaults write, give this command in a Terminal window:

defaults write com.redstonesoftware.Eggplant STShellCommand "/bin/bash"

The initial values of all SenseTalk global properties can be set in this way (there’s a little note in the SenseTalk Reference manual about this, as well as a mention in the Release Notes).

Dang - I’m still not picking up all my export (path) options in bash, though. Not an Eggplant thing, it’s a “I forget things I don’t touch often” thing…