Save As doesn't add .script

I’ve noticed that when I create a new script, it automatically appends the file with .script and the extension is visible in the Suite Editor/Scripts Pane. But if I use the Save As command, it doesn’t add the extension and the script displays in the Scripts Pane without the file extension. I haven’t noticed that it causes any problems without the extension. But I was wondering if there is a recommended best practice for using Save As, and retaining the .script file extension?


What version of eggPlant are you running? Are you on the Mac or Linux platform? I can’t replicate the behavior you describe on the Mac – no matter what I do, the file always gets a .script extension.

Doh! :oops: I just noticed something that answers this question. In the lower left corner of the Save As pane, is a checkbox “Hide Extension”. That might have something to do with what I’m seeing, eh?