RightClick OS9vnc not functioning

I’m having a problem using the right-click command for OS9vnc. I can do a right click(control-click) from the Live Remote Screen ok, but when I try to do it through sense talk it does not work.

I get the following output in the output window:

Tue, 4/6/04 4:15:50 PM rightclick 4911_a at(151,348)

so I’m assuming that Eggplant has sent the command, it’s got to be a problem with OS9vnc. I’ve also used rightClick when testing OSX with no problems.

Is there a known issue about this?

TypeCommand “q” is not working either. This might be an eggplant problem though because I can’t do this from the Live Remote window either. A strange character appears in the browser URL text field

There’s no known problem with RightClick, but I’ll double check it tomorrow. It sounds like one of two things might be happening with the command q:

  1. You might have a modifier key (probably the option key) stuck in the down state. You might test this by typing some characters without any modifiers and see if they go through okay (if the option key is stuck, a “v” will come out as a checkmark). The upcoming Eggplant 1.5 release incorporates some changes that make this situation less likely to occur. You can send TypeText “\A\C\O” to release the command, control, and option keys.

  2. There’s an option on the OS9vnc server to swap the command and option keys. I think this is because internally they are backwards from OS X and the analogous control and alt keys on the PC. You might try changing whatever the current setting is.

BTW, if our responses have been a little slower than usual, I apologize. We have been moving our offices over the last several days and we had some difficulties getting our network going in the new space.

2 was the trick thanks!

I’ve tried all sorts of different combinations of settings between the server and Eggplant to get RightClick to work.(I may have missed a few) Still no Right Click.

OS9vnc running on Mac 9.2.2
Eggplant 1.4 running on Mac 10.3.3

Good luck in your new offices… we will be doing that in a couple months:)

Upon further investigation, it appears that Mac OS 9 has no support for multi-button mice and simply doesn’t know how to respond to a right click. There may be some drivers that are clever and turn a right click into a control click, but I think that’s the best you can do.

So for a control + click, you can use a small handler script (call it ControlClick) that looks like this

params whereToClick

TypeText "\c"  -- control key down
Click whereToClick
TypeText "\C"  -- control key up

and just gets called like this

ControlClick "myImage"

Hope this helps.