Problems with Vine Server and Fast User Switching in 10.4PPC

I have three relevant systems. A Powerbook (G4) that was updated this morning, A G4 desktop running 10.4.9 but at least a touch out of date, and an iBookG3 (original) running 10.2.8. In every case I’m using Chicken of the VNC as the client, and Vine Server 2.1 as the server. I’m not using a system server, but I have the server automatically starting when I login to each user.

The two primary modes are for the iBook to connect to the desktop (desktop is server) and for the desktop to connect to the powerbook (PB is server) (I’m not particularly trying to do this at the same time.) In both cases this works great, IF I’m logging in while that user is logged in. However, using it with Fast User Switching doesn’t seem to work for me.

I know that if I login to another user on the desktop and log back out, the connection to that machine freezes. Vine shows a message about being reinitialized - but restarting Chicken isn’t sufficient, I have to restart Vine. Restarting Vine usually makes it work even without restarting Chicken.

The other configuration is newer to me, but I’m certain that I just tried to use it, and as soon as the PB was user-switched to another user, I could see the login screen and couldn’t interact with anything. Restarting the connection from the chicken side didn’t do anything.

Now, I completely realize this is free software, and that this might be a Chicken problem or, really, is basically an OS X problem, but you’ve been very helpful on lots of threads here, so perhaps you have some pointers for me?

I do all sorts of programming, networking and etc for a living, and I’m not at all afraid to use Terminal if I can do something that would help figure it out. (In fact, if there’s a way to tell Vine to restart from a remote SSH session, that alone would help.)

The latest builds of Vine Server handles this problem well, so hold on for the next release.

Do you have an ETA on that?


Oh, and I forgot - pasting is all lower case, when I copy something from the iBook and try to paste it into the VNC session. Again, might be Chicken…


I believe Eggplant Purple V4.0 has Vine Server 2.2 distributed with it. So qualify for evaluation of Eggplant and you get access to the Vine Server today. It would be speculative to disclose Vine Server open source integration into the OSXserver project. Redstone does not speculate on delivery dates or features of unreleased, announced software.

I downloaded Eggplant purple, and when 10.4.9 (PPC) tries to mount the dmg it gives me the “agree” screen but then a ‘codec overrun’ error and fails to even mount the image.

Please retry, as of Sunday night downloaded and all executable tested to work on x86 and ppc OS X various versions.

Tested on OS X 10.4.9 PB 17" PPC G4, and also verified on MacIntel Mini OS X 10.4.10.

I downloaded Eggplant purple, and when 10.4.9 (PPC) tries to mount the dmg it gives me the “agree” screen but then a ‘codec overrun’ error and fails to even mount the image.

The original post gave me this error on your forums, which I didn’t see until today, and investigating caused an inadvertent repost…

Could not connect to smtp host : 61 : Connection refused


Line : 112
File : smtp.php

Downloading in Safari says “Verification failed”

Downloading in Firefox gives the previously mentioned error when I try to expand it.

I do not routinely have problems downloading software, and I have speakeasy DSL.

Still no issues here, and all our file servers are up and working fine. Two options persist, and that is for a 25+ meg email of the dmg, or you can try a CLI ‘curl -O’ command. If that fails, I’ll see what I can do to burn a CD of the image and send it out to you at no cost for your troubles. Generic CD, no label, no snazzy stuff, just the bits.


I have no idea why that one machine won’t verify just your downloads, but I eventually downloading it using an alternate machine and didn’t have that problem.

So the powerbook is now running Vine Server 2.2 - but I still have the original problem. Specifically, if I login as a user, start Vine, connect, and fast user switch, I lose the VNC connection and cannot restart it.

Vine Server can be run in Desktop (for viewing the original desktop it was started in) or System mode (for viewing what’s on the monitor connected to the computer).

I’m not sure which behavior you are looking.

Please make sure that Vine Server is set to “Restart server if it terminates unexpectedly”. If that is enabled you can acutally just kill the OSXvnc-server process to restart it.

BTW: The lowercase pasting problem is a Chicken bug.