Problems starting server with 2 network interfaces

I’m trying to run Vine server (latest version) on 1.4.8. I found that it sometimes had trouble starting. The dock icon would bounce for a long time (a minute or 2), with Activity Monitor saying it is not responding. Then eventually the window would pop up, but clicking on any tab would result in a beachball for another minute or 2 before anything happened.

Before looking through this forum, I’d never heard of unsanity or APE, so that’s not it. I have found, though, that this only seems to happen when 2 network interfaces are active. This is on an Intel-iMac, and it has wireless and wired interfaces. If I only have one of these active everything’s fine. If I have both active, the problems start (although not 100% of the time, but most of the time). I’ve tried disabling the option to advertise via Bonjour, and that doesn’t make any difference.

Any ideas? Thanks.

I run Vine Server in this configuration (Intel-Mac with both Airport and ethernet enabled and connected) very regularly and have never had this problem.

The only thing we’ve ever been able to track the continual bouncing in the dock to is APE based haxies. You may be using some and not even realizing it, a few examples of APE based haxies (which may or may not directly be incompatible with Vine Server) include FruitMenu, MightyMouse, ShapeShifter, WindowShade, and MenuMaster.

If you aren’t running any of those then please do us a favor. The next time this symptom occurs leave the app bouncing and do the following:
Launch /Applications/Utilities/Activity
Double Click the Vine Server Application in the list of processes.
Hit the Sample Button.
Mail a copy of the sample text to

I had a similar problem, except no window would ever appear - just bounce for a while, then a stuck process in Activity Monitor. I’m only using Ethernet, though the box has wireless too (disabled).

Turns out it was Parallels. With Parallels installed, Vine wouldn’t work for me, just bounce. After I uninstalled Parallels, Vine worked again. Weird, but Parallels does hook the keyboard/mouse/screen too, so I could see it interfering.

Funny thing is I had installed Parallels through VNC, but after a reboot (from the apple software update this week), they wouldn’t work together again.

This is on an Intel Mac Mini; I’ve had no problems with Vine and Virtual PC on my G4 Powerbook.

This problem turned out to be a problem with a DNS server that was not responsive.

We run Parallels here a lot and have never had a problem running both simultaneously (we even connect to a VNC viewer running within Parallels).

I recommend that you look at the DNS network settings of both the Mac and the Parallels side.

As Jonathon said, in my case it was a problem with the DNS server in my Billion router, which is pretty strange. Obviously this one isn’t just a normal DNS forwarder and was trying to do something to resolve local names and screwing it up somehow. I changed the router and the problem disappeared…