odbc: cannot define tables

Fairly fundamental problem - the syntax for setting up tables seems not to work. Code:

// set up connection to db
set myDB to (type:"odbc", DSN:"hub_framework", user:"...", password:"...")
// define tables
set ScriptTable to table "Script" of myDB
// test access to table 
put the records of Script into scripttab
put scripttab

line 4 (set ScriptTable to table “Script” of myDB) gets no syntax highlighting, and results in a syntax error when I run the script.
Image attached.

Windows Eggplant Client, connected to eggplant running in drive mode on ububtu 12.04

The syntax is as described in the documentation, as far as I can see. I’m puzzled

You need to use “ScriptTable” there. You assigned the table “Script” in your database to the variable ScriptTable in the previous line.

True, but it was failing before it gets that far…

Turns out the problem was I was on Eggplant Client v12 or so, and the ODBC functionality was only added in v14. That solved the syntax error around ‘table “Script” of myDB’.

Now I need to work out how to get 64-bit windows to connect to a DSN without complaining about Architecture mismatches (but that probably needs another topic).