keystrokes for cut/paste on solaris xterm/dtterm


I am trying capture text that I have highlighted in a dtterm window running on a solaris machine.

I have tried various combinations of typetext modifiers. My sample code is currently:

drag "dragControl"
drop "dropControl"
typetext "\ci\C"  <- have tried many other combos
put remoteclipboard(15)

Any help is greatly appreciated.


Hope that helps. I’m not sure if Solaris has the same issues as linux, but it sounds to me as if there is no data on the remote system clipboard you just tried to retrieve.

I’m also assuming the /ci/C is for controlDown, “i”, controlUp which will in your terminal application on the SUT do a copy of the currently hilited selection.

Thanks for your speedy reply.

Adding -nowin to vnconfig did not help; however, I got the test work by adding a right mouse click to the right of the highlighted text.

drag "dragControl" 
drop "dropControl" 
rightclick "highlightControl"
put remoteclipboard(15)

I still wonder if there is some keystroke sequence that would also work.