Interesting typeText Problem...


I figured out the double-enter problem. The SUT had the following things set in System Preferences–>Sharing:

[list]Screen Sharing: On
Under Computer Settings, both checkboxes were checked.[/list:u]
Turning all this off fixed the double-enter problem. The lowercase “d” problem is still there, however. Haven’t seen a backtick yet.

Update: I just saw the backtick happen again.

Interesting. I don’t exactly understand why that would have caused a problem. I’m running your demo script now and haven’t seen any lower case "d"s or any other typing glitches.

Okay, Allen, I was able to reproduce the problem. Try switching the VNC server Device preferences from using “Smart Event Management” to “User Session Events”. That seemed to fix it in my environment. I’ll have to talk to Jonathan about why this might be happening – could be a 10.5.5 thing.