Failed to Connect Android 6 -- Nexus 6 over USB

Recently I am working on Android 6 – Nexus 6, I am following the instruction: Connecting to Android SUTs, Launching the Android Server and Connecting over USB: all the steps were fine, I can see my Nexus 6 from the Server drop-down list, but when I click connect button, I got following error message: "Failed to connect to XXXX, Connection Closed by Host. I am not sure why failed. I also tried to lock screen with/without password on device, but won’t help.

By the way, my Eggplant version is 15.02 Mac.



Here are more information: The attached files as following:

  1. VNCPreferences.png is the my VNC Preference information.
  2. ConnectingInfo.png is the my connecting window info.
  3. FailedMessage is the failed connecting message I got.

I also change the port number 5900/5901 without any luck.

Anyone has any idea, why I can’t connect my nexus 6 to my eggplant? Any help will be appreciated.




I am very sorry we didn’t see this sooner - generally you’ll want to write into Support with these types of urgent issues.

Your issue is almost certainly that your version of eggPlant Functional (15.02) is too old. The VNC server for Android is packaged inside eggPlant Functional itself, and we usually include a new version of the VNC server when we release new versions of eggPlant. New versions of the VNC server can include compatibility with new devices and new versions of Android. Keeping eggPlant Functional updated is especially important for this reason.

Hopefully this helps.


Thank you very much for your patient to answer my question. Yes. It worked after updated my eggplant version to 15.22.

Thank you again.