Errors - Where to find a list of what each error means

Hello. Relative EP newbie here. I’ve done lots of scripting using images I’ve captured on the website I test, but now I’m trying to make the same tests work across XP, Vista & OSX using Firefox, IE6 & 7, and Safari, so I’m really starting to digg into TIG.

Is there a listing somewhere of error messages and their meanings?

‘Too Large’ is the error I’m trying to track down. Anytime I click Text Image on the toolbar & put in even 1 char, I get:
Error Generating Text Image – Error: ‘Too Large’ while reading Image Info size from Server (my ip address:5900)


Please elaborate:

  • the details of your configuration, Eggplant version, hardware, network, SUT system, so forth. More details the better.
  • Have you installed the Windows TIG V1.02 and .Net 2.0 on your windows SUT?

We’re interested in solving this problem, but need more details to help track down the issue at hand.

EP: 3.3
Mac: OSX 4.9, 2 GHz Intel
Network: 100Base-T, dev & SUT on same subnet
SUT: WinXP-SP2, P3
RealVNC 4.1.2, starts as a service

Windows TIG V1.02 - I’ve found this on /downloads & am going to run it on the SUT. I’m also now installing .net2 on the SUT as well.

Thanks for the pointers. How about the error message listing, is there such a doc?


You shouldn’t get any meaningless errors unless there is some configuration problem or .Net not being installed. As for a error to english translation mapping list, we do not have one availalbe for public consumption :slight_smile: Just post if you continue have problems. Please read the posts in the forums about TIG usages. Search for “TIG” and you will find quite a bit about it. See also and study the Eggplant Text Image property list information in the back of the Eggplant Reference Manual for more detailed information.

Howdy. I was able to resolve the ‘Too Large’ error. In Preferences > Text, the generator was not set to ‘Native’. So now that portion is working. But I’m still trying to get TIG working & I’m not sure what I’m doing wrong.

Suggestion for the ‘Eggplant Examples’ section: A suite that points to a popular but fairly simple website, maybe classic. Using TIG, the script gens images for the images/news/maps links on a XP SUT, then does the same on a OSX SUT. That would be handy imo.

I’ve pulled some repeat code from other examples on the forum to cycle through fonts & sizes, still no luck. If I use CaptureTextImage first, it works, but if commented out fails.

set the currentTextPlatform to "WindowsClassic"

TypeText controlDown
TypeText escape
TypeText controlUp
TypeText "r"
TypeText "iexplore"
Click (150, 595)
TypeText "\r"
Wait 5

CaptureTextImage ( text: "Calendars", rectangle: (417, 170, 489, 185) )

put "Arial" into tFont

repeat with tsize=7 to 11 step .5
	if ImageFound(0, (text:"Calendars", textSize:tsize, textFont:tFont ))
		Click foundImageLocation()
	end if
	if ImageFound(0, (text:"Books", textSize:tsize, textFont:tFont, tolerance:40))
		Click foundImageLocation()
	end if
	if ImageFound(0, (text:"PhotoWorks", textSize:tsize, textFont:tFont))
		Click foundImageLocation()
	end if
	if ImageFound(0, (text:"Cards", textSize:tsize, textFont:tFont))
		Click foundImageLocation()
	end if
end repeat

Since you’re a connecting to a Windows SUT, you don’t want the Text Image Generator set to Native. Doing that tells Eggplant to use the built-in text generator, which will only work for SUTs that are running Mac OS X.

Switching to Native gave the appearance of resolving the “Too Large” error for you because Eggplant was no longer talking to the Windows TIG, but that won’t get you very far. Select “Host” instead, and set the host name to “Current SUT” so Eggplant will talk to the TIG on the SUT.

The “Too Large” error probably indicates a communication problem of some sort with the TIG. Please make sure you are running the latest TIG on your SUT (it sounds like you are) and verify which port number it is using (make sure it matches the port number shown in the Text Preferences panel).

If that all seems correct, please let us know exactly what settings you’re using in generating the text image so we can see if we can replicate the problem here.

Excellent. Now I’m getting there.

So I’m trying to setup DefaultTextStyles corresponding to the font usage areas of my site in Text Preferences. However, when I click buttons such as ‘Set As Default’ the following exception is thrown, even though the change seems to take (verified by clicking another item such as Mail & then back to Text).

But, when I try to ‘Add’ a new Text Style, I get the same error. But the ‘New Style Name:’ window popsup & cannot be closed as the Cancel & Add buttons have no effect. The only remedy is to force quit EP. I’ve not found this error using the forum search.

*** -[EggplantApplication vncConnection]: selector
not recognized [self = 0x67c020]

You’re now running into a bug that was accidentally introduced in Eggplant 3.3. If you are eligible for the new 4.0 upgrade, I would encourage you to do so (click the Downloads link at the top of this page, then click the “Eggplant Purple” link). If you’re not ready to upgrade to 4.0 yet, then please click here to download Eggplant Purple 3.31 which corrects this problem.