Error Generating Text Image


  I tried creating a text image using text image sheet but i am not able to create and it shows up a socket error 10061.

Could you please help me sort this out

My guess is that you haven’t installed the TIG executable on the machine that you are testing.

I have installed it now ,still i am getting the same error

Just to be clear, you installed it on the system-under-test, not on the eggplant machine itself?

BTW, this is the kind of issue that should be handled via e-mail to the support address, not through the forums.

Is there a TIG for a Linux SUT using a Win XP controller? The Pango one appears to be for a Mac controller.

Currently to use Text Images against a Linux SUT from either the Linux or Windows version of eggPlant you need to create a “scripted TIG”. There is a document at that describes this process. Essentially you’re typing the text on a Linux machine (either on the SUT itself or on a similarly configured Linux box), then capturing an image of the typed text and trying to match it against the application. This can be a fairly simple thing to set up if you just need text in single font/size/decoration with consistent colors; it becomes more complex if you need to use several fonts, change the properties, or use different font colors and background colors. But once it’s written, its use is transparent; if you set it as the text platform, your text image calls will use it to generate text images with no other changes.

It’s very difficult to create a standalone TIG application for Linux, in part because there are several different rendering engines available for applications to implement – the TIG would either have to be able to switch engines or else be written to specific one, which would still leave people testing apps that used the other ones out in the cold. That said, we do hope to provide improved TIG functionality for Linux and other platforms in the future.