Eggplant v10 Mac version problem


I’m trying out this new version of Eggplant for Mac with a trial key. I keep on getting this NSInvalidArgumentException and I have no idea why. The scripts I’m trying with this new version had no problem with the older version(4.2 I believe). Could you tell me when this exception happens?

*** -[STGenericObject objectValue] unrecognized selector sent to instance 0x15dc5d30


That definitely sounds like a support issue – would you please send any script sample of when it occurs to our support@ address.

If it doesn’t occur regularly on a particular line it would be a help to at least see what sort of actions you are doing in your script that might be triggering it.


I think omega13 is causing the problem.

start using omega13
start using AttemptRecovery

WaitFor 60, “SomeImage”
log “Didn’t Find anything”
end try

stop using AttemptRecovery
stop using Omega13

It goes to “Didn’t Find anything” without waiting for “SomeImage”. If you comment out the omega13 stuff, then it normally wait for “SomeImage”.

I tried commenting out omega13 from my script as well and it works fine, no more NSInvalidArgumentException. (?_?)

Did anyone try that code above on v10?

We can confirm this problem on v10 and it will be fixed in the next release.

But you don’t need to wait, there is a simple fix that you can perform yourself. Just replace the Omega13 script with the one attached here (it lives at

That fixed it. Thanks.