Eggplant incompatible with leopard?

I’m running OSX 10.5.1. Every time I use eggplant (I believe, typically after I run a script) Eggplant seizes control of my system, not allowing me to switch focus to any other app (or if it does, it won’t let me input data into those apps - eggplant keeps input focus no matter what).

If I quit eggplant, my menu bar goes away and I can’t switch focus to any application. I have to hard-reboot my system, since it’s at this point useless.

Is this known? Is there a fix?

I’ve tried it with both 3.3 and 4.1 beta 3.

If it is relevant, my source files are on a NFS mount.

We’re sorry to hear about you having problems that extreme – we can honestly say that we’ve never heard of that issue using Leopard (or Tiger or Panther).

We do not typically run any NFS mounts but that seems unlikely to be the culprit (in and of itself).

Are you doing something against the same machine like a “subSut / OffScreen account”?

I don’t believe I’m doing any of that, mostly because I’m not sure what those things are.

You can setup a second account, fast user switch to it, launch a VNC server, switch back to your Eggplant/User account and then connect to that VNC server and control the other desktop.

So, assuming that you aren’t doing that is there anything else that you can describe about your setup that might be causing a problem? Have you experienced it on more than one machine?

No, I’m not doing anything of that kind. I’m connecting to a remote SUT.

The only things that are different than when I previously used eggplant are upgrading to Leopard, having my source NFS mounted, and a few changes to how the user account is set up (for example, FileVault, and I’m a remote user).

I haven’t tried it on any other machines, though I suppose I could try on my laptop.

Some of that is a little atypical from our usual configuration, but it should “just work”.

I guess the best thing is to try removing a few variables – probably from easiest to hardest I guess it seems like:
[list][]NFS - Try Copying the Source Locally
]FileVault - If this isn’t a corporate requirement
[]Local User vs. Remote User
]Another Machine[/list:u]
I’ll try to do some testing here with FileVault and Remote User but the NFS will be tricky to replicate your exact mounting setup.

Please let us know if you are able to identify a pattern – if there is something we need to fix in Eggplant to support that environment then we’ll be sure to do so.