Eggplant Functional 22.5.0 (Linux) on Fedora 38


I’ve been wanting to leverage some of the GNU/Linux native tools with Eggplant and decided to take a stab at installing EF 22.5.0 on Fedora 38. Since the rpm installation notes instruct to --force install to /usr/GNUstep/ I gave that a try but was informed by rpm that package Eggplant is not relocatable. It’s been a while since I worked with rpm but I do recall this warning :slight_smile:

I ran rpm -qlp Eggplant22.5.0.rpm and noticed while most of the files go to /usr/GNUstep not all do. After the installation I also found a GNUstep directory in my home directory which I hadn’t seen listed during the -qlp query.

When I ran eggplant default from the command line most of the errors were related to fonts not found, with exception to these:

2023-06-06 22:52:38.321 Eggplant[3293:3293] Exception occurred while loading model: Tried to add nil value for key '511BCEFB-19E6-C808-6296-D79DC7BC0135' to dictionary
2023-06-06 22:52:38.322 Eggplant[3293:3293] Failed to load Xib
2023-06-06 22:52:38.391 Eggplant[3293:3293] Cannot load the main model file 'MainMenu'
time="2023-06-06T22:52:38-07:00" level=info msg="Eggplant (Command Line) is 22.5.0-Linux-64, build (202304070410), commit (1cc6ca61), on Fedora Linux 38 (Workstation Edition) ICU version 50.2" Sub Component=EPF
2023-06-06 22:52:38.453 Eggplant[3293:3293] FAILED TO LOAD or CREATE THEMES: JSON Parse error

My follow-up to this initial install is to see about getting everything under /usr/GNUstep somehow that doesn’t involve rpm (I wound up installing using dnf in the end so may see if I can use that to force the install where rpm wouldn’t). But before I dive back in just wanted to toss this out there and see if anyone has installed recent EF Linux releases on any Red Hat or similar systems.


Just as a follow-up to this, I decided to try Ubuntu 22.04 instead and the installation of Eggplant Functional went “fine”. Since I’m not bound to any one OS I can use for Eggplant testing, I’ll stick to the “easier” route :wink:

Notes on that install here: