Case sensitive password


I am having this issue when I am typing text in a password field. I have written this command

TypeText “Password123”

Instead of writing Password123 eggPlant is writing password!123.

So there are 2 problems.

  1. I want it to write capital P

I tried this code but it is not working

TypeText “Password123” considering case

  1. Secondly it is typing ! in place of 1

Please advice what needs to be corrected


Is your SUT a Mac running Vine Server? If so, then you need to open the Vine Server preferences and under the Advanced tab set the Event Source dropdown to “10.3 API (No Source)” and the Keyboard Events to “Hardware Events”.

If not, then we need a lot more information on your configuration on both sides of the connection.

No my SUT is an Android device and I am writing a script to log on to twitter that opens in a web view from my app. As passwords are case sensitive so I want it to write exactly what I am passing in TypeText command.


If you are working against DroidVNC then it would appear that there might be an issue with that server (although we’ve not observed it). If you are working with the RealVNC Mobile server then we need more information about which version and which device you are working with.

One suggestion is to try disabling the “Send Shift Key for caps” setting in the preferences. As shown in the image.

Or you might be able to avoid that by sending two strings:

TypeText "Password"
TypeText "123"

can u try this code
TypeText CapsLock
TypeText Password123
but i tried this code only in windows Xp PC only