Can't run multiple machines on same network

This is driving me nuts. Here’s my setup:

My DSL service comes in thru a Netopia router/switch in a back room. Directly off the Netopia I ave a network camera port forwarding thru 8000 (this may be an irrelevent fact, but…). I run a LAN from the netopia out into my showroom and connect to a D-Link 10/100 switch. On the switch are the following:

2 iMac Intel Core 2 Duos. Each has an Admin User and a Managed User. We will call Them A and B for reference. So, in essence I have 4 virtual machines on the network. Currently I have Vine Server set up on the Admin side of each machine as a System Server. I had thought, and hoped, that when setup per the docs that that’s all I would need. That in the Server mode I could remotely access either side of the machine and even switch users. But that is not the case.

I can only access one Admin side of one iMac - currently on iMac “B”. I should note that before I was running Vine Server as a System Server, I was running it on both non Admin sides of each iMac as a Desktop Server - at that time I was able to access remotely via Vine Viewer iMac “A”, non Admin side.

So, I now have also launched Vine Server (Desktop mode) on each non-Admin side of both iMAcs. I can only get one (1) machine at a time to be accessed remotely via Vine Viewer as stated before on aiMac B Admin side.

I’ve tried changing the Vine Server to allow multiple VNC clients (out of desperation) to no avail. When I set up all the machines on Vine Viewer I get my one connection to iMac B just fine, but on two other “machines” I get the message Connection Refused and on the one other I get Connection Timed Out.

Im pretty certain I’ve got the ports forwarded on the Netopia properly. ALthough not that I think about it maybe I only have 5900 and 5901 forwarded (My iMacs are setup using 5900, 5901, 5902 and 5903).

I’d really like to only have Vine Server running as a System Server once on each machine. Can I do this?

How can I get all 4 machines up on the network and accessed remotely? Where am I messing up? I’ve read the manual backwards and forwards. I’ve attached some screen shots of key setup prameters from each iMac, (some taken before I enabled Allow Multiple VNC Sessions and restarted the server to take effect).


Portforwarding needs to be used. Port 5900 for instance should go to machine 1 behind the firewall. 5901 thru 5903 should be forwarded to
the respective hosts. Then each machine should have pass word protection on, allowing only users that know the password to gain access to the remote system running Vine Server. Allowing just one connection is fine and a good idea in this case if you indeed only want one person to connect to a given machine. I have tested this configuration on our lab network and it works fine. YOu may need to research the hub/router you are working with and find out how to set it up properly.

As I stated I have port forwarding set up on 5900 and 5901 and can’t get the 2 to work simultaneously.

That being said, I went ahead and set up port forwarding on 5902 and 5903 with exactly no change in symptoms.

What may help me a bit is to know what is the difference between a “Connection Refused” and a “Connection Timed Out?” That is, what is failing in the handshake?


It’s not cut and dried, and either can be caused by a router’s Firewall; but…

Connection Refused –
Generally means you are getting to a device but are trying to communicate on an invalid port. This can be because:[list=a][]It’s being rejected at the router level (no forwarding setup)[]The Server isn’t running on that port on that machine[]The firewall is configured to reject it (The Internal Apple Firewall acts this way.)[/list:o]
Connection Timed Out –
Means you aren’t getting ANY response on that IP/Port. This usually means.[list=a][
]You are pointed at an incorrect IP[]The forwarding is pointing at an incorrect IP[]The firewall is configured to “IGNORE” requests on that port. (Some router firewalls do this instead of rejecting)[/list:o]

Hope that helps. The scenario you describe is definitely doable if everything is properly configured. We do it here on a regular basis.

Thanks! I got it all working.

Let’s just say, I know a lot more about Port Forwarding now. :wink:

I have 2 iMacs, each with an Admin user and a non-admin user, on the same LAN. On one I have Vine server running only on the Admin side and I seem to be able to see both the Admin and non-admin sides remotely ---- that is until I reconfigured the other machine (because for some unknown reason I stopped seeing the non-admin side of the other machine). It seemed (unbelievably) that the port on the iMac’s internet sharing preferences had been changed…?

On the other I had Vine Server running on both the Admin and non-admin sides and it was working fine. ( I always wondered why I needed to have Vine Server running on each side).

AT one point I could remotely view all 4 (virtual) machines. Now I can’t, and I can’t really understand why. All I’ve done was to power up and down.

It seems things come up in different states after cycling power.

Now that I’ve changed the port to what it seems it should be, I’m in even worse shape than before - I used to only NOT see one non-admin side. No w I can’t see one user on each machine.

Any insights appreciated!

Sorry for the delay on a response –

Without knowing more details about the nature of the connection failure let me suggest basic troubleshooting steps.

To access any virtual account it must be currently logged in and each account must be running a Vine Server on a unique port. (For more than one account on a machine this means using Fast-User-Switching to get to it, not SSH or Telnet)

Once the above is certain we can try to isolate the problem. Is this ONLY a problem going through your router? Meaning when you are on the local network can you access the 4 virtual accounts?