Can't find image after running Omega13 attemptRecovery

So I am trying to use omega13 to deal with some of the random popups and issues that arise from the network here. For example like random authentication.
–So opencheckforupdates just opens a program and sometimes a random prompt will come up for authentication so the image it is looking for is not found so then the attemptrecovery handler is called and deals with the random prompt by closing it and letting the proper program open.

start using Omega13
start using test34

–sets days to 0 in SPU
DoubleClick “SBT/SPUDaysSelect”

to handle attemptRecovery param1, param2, param3

if  item 1 of param3 contains "SPU" then 
	click "Button/Cancel"
	Wait 10 Seconds

end if 
return no

end attemptRecovery

After the attemptrecovery it goes back to the doubleclick after the checkforupdates and can never find that image but using image doctor it finds it no problem. I have tried a screen refresh and giving it enough wait time. Any ideas if I am doing something wrong here? The test34 is the actual script where the attemptrecovery is found because I need to use it with multiple scripts and don’t want to put the attemptrecovery in every script. Also the image that the doubleclick is looking for is called from a helper.

Try adding “return yes” before the “end if” – the attemptRecovery handler needs to return YES to let the omega13 script know that it did something to handle the problem.

That worked thanks.