Cannot connect remotely

I set up vine server on my mac pro and vine viewer on my macbook pro. On testing on my lan, I easily connected and transferred files. I then checked the external connection IP and had no issues there, while on my LAN. I checked on and got all passing grades with the Mac Pro’s Vine Server.

I am testing the remote connection now and cannot connect with or without ssh. I am connected on outside wi-fi at a merchant and can get email and get online.

I was first trying the IP address I was using on the lan and realized that would only apply at home. I am very new to vnc of any kind. I then tried the router IP I wrote put in a text file on my MBPro, along with the ssh info. No go. I have a feeling this should work and is suffering from user error. But, the merchant is t-mobile and I have had issues with them when using hotspot vpn.

I have the port forwarded to 5900 as instructed in several resources.

Any input. I’m in a time crunch, as my time left here is about 15 minutes.

Thanks in advance.

It sounds like you did set everything up correctly for regular VNC traffic, especially if you verified with

You do want to use the external router address when connecting from outside your LAN.

In order to connect with SSH you would need to forward port 22 to the MBPro just as you did for 5900.

It’s probable that the hotspot ISP you were using only allows communication on certain ports (80 for HTTP, 25 for SMTP, POP, IMAP, etc) and was not allowing traffic on 5900. It’s likely that they would have allowed traffic on SSH (port 22) but I can’t say that for sure.

Sorry that this reply comes to late for your particular session at the hotspot; but hopefully the next time your out you can make use of it.

I actually have port 22 mapped for ssh, already. It wouldn’t let me through that tunnel either. I have informed t-mobile and am certain it’s their setup. I am going to try another location today. Thanks for the reply.

Well, now I’m totally lost. I have tried to connect outside of my home using my EVDO and my mom’s network, but no luck. says everything’s okay. But, no matter what I enter in the connection boxes, my connection fails. Someone save my sanity. It can’t be this hard.

Use the same external IP value for the Server and the SSH host, I think that will get you connected.